How to install Apache Flex 4.8.0 SDK in Flash Builder

In this post I’ll explain in an easy step by step tutorial how to install Apache Flex 4.8.0 in Flash Builder, I know that it’s not rocket science but maybe newbie developers could need more information to start play with new SDK.

The new SDK is more or less the same of 4.6 but under Apache flag, like you can read at Spoon website, but we hope people behind the project could give us new opportunities for our RIAs and Mobile projects.

So let’s start!

First of all download Apache Flex 4.8.0 binaries for your operating system (in my case OS X), keep attention, you need the binaries release not the source one.
After unzip the downloaded file create a folder called 4.8.0 in /Applications/Flash Builder 4.5/sdks

Then download playerglobal.swc for Flash Player 11 on Adobe website.

Save it in /Applications/Adobe Flash Builder 4.5/sdks/4.8.0/frameworks/libs (it could be better create a folder called “player” or as you want, in my case I use “11.1″ and save the swc inside).

Finally, open Terminal navigate trough your folders and position it to this location /Applications/Adobe Flash Builder 4.5/sdks/4.8.0/frameworks then launch this ANT command:

ant thirdparty-downloads

After 10 minutes you will download everything:
. OMSF dependencies
. TLF framework
. Flex 4.6 SDK and so on

Last but not least, in Flex 4.8 SDK folder you will find a env-template.properties, you have to duplicate the file, call env.properties and set the right path for each folder:

env.AIR_HOME= path to AIR SDK on your filesystem

env.FLASHPLAYER_DEBUGGER = path to Flash Player Debugger, if you have Flash Pro installed you can find a version in Players/Debug/Flash Player Debugger

env.PLAYERGLOBAL_HOME= path to playerglobal.swc (it's not an absolute path, it's relative and starts from frameworks folder in Flex SDK!!!)

env.PIXELBENDER_HOME= path to Pixel Bender Toolkit 2 (it's not important to set if you don't use it)

env.ADOBE_EXTENSION_MANAGER= path to Adobe Extension Manager

Remember that in template file you can read an accurate explanation on how to set those environment variables

Then you can start to enjoy the new Flex SDK.

The team behind Flex in Apache is working on a new AIR application that will help you to install in Flash Builder the SDK but it's not released yet... we hope to have it soon, in the meanwhile I hope this tutorial could help you to set your IDE.
There is another way to install the SDK trough an AIR app that you can download from here: http://people.apache.org/~bigosmallm/installapacheflex/
If I forgot some steps in my description please comment to this post to help everybody to enjoy Apache Flex, thank you in advance.

About these ads

50 thoughts on “How to install Apache Flex 4.8.0 SDK in Flash Builder

  1. Pingback: How to install Apache Flex 4.8.0 SDK in Flash Builder « eaflash

  2. Pingback: Apache Flex 4.8.0 liberada: versión par con la 4.6.0 de Adobe

  3. ….
    impossibile aprire “C:\Program Files (x86)\Adobe\Adobe Flash Builder 4.5\sdks\4.8\frameworks\\player\11.1\playerglobal.swc”
    ….
    ;-((((

  4. Alternatively, on Mac OSX, you can download and unzip the binaries into a directory.

    cd apache-flex-sdk-4.8.0-incubating-bin/ide/flashbuilder
    ./makeApacheFlexForFlashBuilder.sh /Applications/Adobe\ Flash\ Builder\ 4.5/sdks/4.8.0

    The script will pull together all the parts you need and copy the sdk to the specified directory.

    There is also a bat script but it has some limitations so I would recommend using the AIR app on Windows.

  5. Any idea how to correct this error or what’s causing it?

    unable to open ‘D:\Program Files (x86)\Adobe\Adobe Flash Builder 4.6\sdks\4.8.0\frameworks\D:\Program Files (x86)\Adobe\Adobe Flash Builder 4.6\sdks\4.8.0\frameworks\libs\air\airglobal.swc’ project-iOS Unknown Flex Problem

    Thanks, in advance

      • I was using an absolute path as the env-template.properties file says to use absolute. I changed it to relative and still getting an air. For example, my AIR_HOME is set to AIRSDK. I now get the following error:

        unable to open ‘D:\Program Files (x86)\Adobe\Adobe Flash Builder 4.6\sdks\4.8.0\frameworks\AIRSDK\frameworks\libs\air\airglobal.swc’ Unknown Flex Problem

        Looks like it is appending the relative path to an existing path.

        Thanks for your assistance!

  6. Pingback: Apache Flex 4.8.0 Released! | Devgirls Weblog

  7. The SDK installation was perfect.

    When you open the IDE Flash Builder 4.6, select an existing project, change the version and displays a warning message when you press the Desing:

    The Design Mode is disabled to use as the project incompatible version of the Flex SDK

  8. Pingback: Apache Flex 4.8.0 | Carlos Zaragoza

  9. Pingback: Apache Flex Community Revue Aug 2012 | Open Spoon Foundation - Spoon Project

  10. i was successfully install flex 4.8 in flash builder. after run and that is nothing display in browser . anyone can assist. thanks

  11. I successfully install flex 4.8 in flash builder 4.7 beta, I follow ALL your instructions but after Run a simple proyect, web page and that is nothing display in browser some Idea?

  12. After seeing how this synergy of adobe and apache is for flex, I deleted all adobe flash builders and flex related products. We used adobe products because we expect a certain advantage from commercial products, but this is just bullshit. When in a time everything can be simplified and automated and we have to go back resorting classic ways of configuring/developing like 10 years ago. No, thank you.

  13. I have used the installer to install the sdk 4.8.0 and I have noticed the file swfobject.js is missing from project files. so you will have to manually add it to the project and to the template folder on the sdk. This caused the app failed being added/embeded to the page.

  14. hello, to let working airglobal.swc I had to:
    - paste/merge airsdk all content dir in flexsdk dir
    - edit env.properties:
    env.AIR_HOME=
    (leave blank)

    edit air-config.xml (line 83):
    {airHome}

    :)
    Jaco

  15. oops, some comment content was stripped:
    node in air-config.xml:
    [path-element]{airHome}[/path-element]
    (change with appropriate brackets for xml compliance)

  16. I have the “old” version of Flex Builder (4.0). I know we can also add SDKs but I had troubles when trying the SDK 4.5. Do you know if it works better with the SDK 4.6 or the new 4.8 ?

  17. I installed apache-flex 4.10 in my flash builder 4.6 (by apache-flex-SDK-installer), but the design mode is disabled, why? How do I do to enable it?
    thanks

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s